Microsoft Teams Articles / Blogs / Perficient https://blogs.perficient.com/tag/microsoft-teams/ Expert Digital Insights Mon, 07 Jul 2025 16:49:53 +0000 en-US hourly 1 https://blogs.perficient.com/files/favicon-194x194-1-150x150.png Microsoft Teams Articles / Blogs / Perficient https://blogs.perficient.com/tag/microsoft-teams/ 32 32 30508587 Erin Zapata Champions Dynamic Collaboration in Perficient’s Microsoft Business Unit https://blogs.perficient.com/2025/07/07/erin-zapata-champions-dynamic-collaboration-in-perficients-microsoft-business-unit/ https://blogs.perficient.com/2025/07/07/erin-zapata-champions-dynamic-collaboration-in-perficients-microsoft-business-unit/#respond Mon, 07 Jul 2025 16:49:53 +0000 https://blogs.perficient.com/?p=383235

Meet Erin Zapata, a Practice Director based in Chicago, Illinois, whose empowering leadership and commitment to professional development have made a difference for Perficient’s Microsoft Business Unit (BU). As a member of Perficient’s Women in Technology (WiT) Employee Resource Group (ERG), Erin is dedicated to creating a supportive and inclusive workplace that fosters meaningful connections. With her exceptional skills in team management and project delivery, she champions client success and encourages a collaborative spirit that inspires those around her 

In this People of Perficient profile, we’ll explore Erin’s expertise, passion for continuous learning, and remarkable career journey over the past 13 years at Perficient. 

What is your role? Describe a typical day in the life.

I began my career with Perficient as a Senior Technical Consultant after a decade at a large consulting firm. Over the years, I progressed through various levels. About four years ago, I was promoted to Delivery Director. Most recently, I have taken on the role of Practice Director of Modern Work and Security. At each stage, I felt prepared and empowered to embrace new responsibilities, thanks to the invaluable lessons learned along the way. Every engagement, pursuit, and customer interaction has imparted knowledge that I carry forward into each new initiative. 

As a Practice Director, I have a handful of responsibilities in various areas. I work with my team to develop, modify, and execute the strategic vision for our Microsoft Modern Work and Security practices. I support with aligning the vision with business goals and market trends, while monitoring revenue and utilization. I oversee the project delivery of solutions, acting as a point of escalation for both internal and customer issues. From a team management perspective, I provide guidance to a team of skilled directors, consultants, architects, and developers. Lastly, I support pre-sales activities, collaborate with sales and marketing teams, and help pursuit teams through the sales cycle.  

How do you explain your job to family, friends, or children?

When asked, “What do you do?” I typically say, “I help our sales organization sell Microsoft solutions, and our team helps our customers roll out Microsoft capabilities like Teams and SharePoint to their organizations.”  

Whether big or small, how do you make a difference for our clients, colleagues, communities, or teams?

One of the most rewarding aspects of my role is fostering an environment where my team members can thrive. I am committed to ensuring that they are engaged in meaningful and enjoyable work, feel valued for their contributions, and receive the support they need to succeed. Their well-being and professional satisfaction are paramount, and I am dedicated to being their advocate. 

What are your proudest accomplishments, personally and professionally? Any milestone moments at Perficient?

Personally, my greatest achievement is undoubtedly my children, of whom I am immensely proud. Family is always my top priority, and their well-being and happiness are essential.  

Professionally, my most significant achievement was the successful delivery of an application for an exceptionally challenging project with 86 consultants in 11 different BUs. I am incredibly proud of our consultants for going live with this application. It was a remarkable demonstration of Perficient’s collaboration and dedication, which showcased our commitment to excellence even in the face of daunting circumstances. 

With Perficient’s mission statement in mind, why do we obsess over outcomes? 

Our mission to obsess over client outcomes is rooted in our commitment to excellence and our belief that our clients’ success is our success. 

READ MORE: Perficient Obsesses Over Client Outcomes to Drive Client Success 

What motivates you in your daily work?

I am inspired by the talent of our team and the collaborative environment we foster. The challenge of solving our customers’ complex problems keeps me engaged and passionate about what we’re accomplishing together. Knowing that our efforts make a meaningful difference for our clients drives my commitment each day. 

READ MORE: Perficient Colleagues Make a Difference 

What has your experience at Perficient taught you?

My experience at Perficient has taught me many valuable lessons, but two stand out. First, the importance of fostering a collaborative work environment where every team member feels valued and empowered, creating a positive workplace experience. Second, navigating complex challenges has taught me the significance of adaptability and maintaining a positive mindset.  

What advice would you give to colleagues who are starting their career with Perficient? 

My advice for new colleagues is to embrace continuous learning, stay curious, and ask questions. No one knows everything, and there are so many wonderful, bright people to learn from at Perficient who will help you grow in your career.  

Why are you #ProudlyPerficient?

I am #ProudlyPerficient because of our commitment to excellence and innovation, as well as the amazing people I work with who keep me motivated and positive. I stay here because I feel supported by my leadership, and my colleagues are invested in my growth.  

LEARN MORE: Perficient Fosters Growth for Everyone 

What’s something surprising people might not know about you or your background?

Many years ago, I was a nationally ranked figure skater. 

What are you passionate about outside of work? 

Outside of work, I am passionate about family and community. Right now, our family focus revolves around academics and sports. My sons play multiple sports, and my husband dedicates his time to serving on the board of a community youth sports organization and coaching our boys’ football teams. I love watching them play, be part of a team, thrive in school, and actively participate in our community. I make it a priority to never miss my kids’ sporting or school events. Being there for them is critical to achieving and feeling that work-life balance. 

SEE MORE PEOPLE OF PERFICIENT 

It’s no secret our success is because of our people. No matter the technology or time zone, our colleagues are committed to delivering innovative, end-to-end digital solutions for the world’s biggest brands, and we bring a collaborative spirit to every interaction. We’re always seeking the best and brightest to work with us. Join our team and experience a culture that challenges, champions, and celebrates our people. 

Learn more about what it’s like to work at Perficient at our Careers page. See open jobs or join our talent community for career tips, job openings, company updates, and more! 

Go inside Life at Perficient and connect with us on LinkedIn, YouTube, X, Facebook, and Instagram. 

]]>
https://blogs.perficient.com/2025/07/07/erin-zapata-champions-dynamic-collaboration-in-perficients-microsoft-business-unit/feed/ 0 383235
Create and Manage Microsoft Teams and Channels with PowerShell https://blogs.perficient.com/2024/12/24/create-and-manage-microsoft-teams-and-channels-with-powershell/ https://blogs.perficient.com/2024/12/24/create-and-manage-microsoft-teams-and-channels-with-powershell/#comments Tue, 24 Dec 2024 06:05:32 +0000 https://blogs.perficient.com/?p=374149

In this blog, we will walk through the process of creating a Team, adding Team Channels, and managing owners and members within Microsoft Teams using PowerShell scripts. You’ll learn how to automate the creation of Teams, organize them with different channels, and efficiently manage user roles and permissions, such as assigning ownership or membership. This will help you streamline administrative tasks in Microsoft Teams, enabling you to maintain better control and organization within your Teams environment.

Prerequisites for Creating and Managing Microsoft Teams with PowerShell

For executing certain commands, you should have the Microsoft Teams PowerShell module installed on your computer. Use the PowerShell cmdlet below to install the Microsoft Teams PowerShell module. I am performing this in PowerShell ISE.

Install-Module -Name MicrosoftTeams -Force -AllowClobber

Once the setup is completed, open the PowerShell ISE in administrator mode and set up a new team.

Create a Team with PowerShell

To work with Teams using PowerShell, connect the Teams module by importing it in code as follows:

# Sign into Teams online
Import-Module -Name MicrosoftTeams
$credential = Get-Credential
Connect-MicrosoftTeams -Credential $credential

You will be prompted to enter your credentials when you execute the above commands. Ensure that you provide the admin credentials for Microsoft Teams.

Next, create the team as either Private or Public using the following command:

New-Team -DisplayName <TeamName> -Visibility <Private/Public> -Description <DescriptionAboutTeam> -MailNickName <AliasName> -Owner <TeamOwnerEmail>

Ex: New-Team -DisplayName  “Test Team” -Description “This Team is for testing purpose” -Visibility Private -MailNickName TestTeam -Owner abc@xyz.com

Note: Changes made to Teams via PowerShell may take up to two hours to take effect and appear in both the Office 365 admin portal and the Teams client.

Once the team is created, it will display the information about the newly created Team as follows:

Newteam

Parameters

  • Visibility: Public Teams enable any user to join the group, while Private Teams require approval from an owner before a user can join.
  • MailNickName: Email alias for the associated Office 365 group. MailNickName will be used as the PrimarySmtpAddress.
  • Owner: The Team owner can add or remove people from the Team. If the owner is not specified, it is set to the admin user who created the Team.

Add Users to a Team

To add users, you need the GroupId. Use the PowerShell command below to retrieve the GroupId based on the Teams display name.

# Get Team ID
$Group = Get-Team -DisplayName <TeamDisplayName> | select GroupId

This command will return the GroupId, display name, visibility, description, and other details. Then, add the users to the group by executing the following cmdlet.

# Add user to Team
Add-TeamUser -GroupID $Group.GroupId -User username@xyz.com

By default, it adds the user as a Member of the Team. To add a user as the owner of a team, include the -Role parameter and set its value for the owner.

Remove Users from a Team

# Get Team ID
$Group = Get-Team -DisplayName <TeamDisplayName> | select GroupId
# Remove user from Team
Remove-TeamUser -GroupID $Group.GroupId -User abc@xyz.cloud

Once a user is removed from a team, they can no longer access the team’s channels, files, or conversations.

Note: Only the team owner has the authority to execute this command and remove a user

Create Channels for a Team

After the team is created, you can add a channel to it. To do this, use the New-TeamChannel cmdlet with the following syntax.

New-TeamChannel -GroupId $GroupId -DisplayName <NewChannelDisplayName> -MembershipType <Private/Shared/Standard> -Owner <UserEmail>

Parameters

  • MembershipType: Channel membership type, Standard, Shared, or Private.
  • DisplayName: Name of the channel that needs to be created
  • Owner: UPN of owner that can be specified while creating a private channel.

Note: A SharePoint site is also generated when a private or shared channel is created in a team. Access to this site is restricted to the owners and members of the respective private or shared channel.

A team site is automatically created in SharePoint whenever a new team or a private/shared channel is created in Microsoft Teams. The site’s description or classification can be edited within the channel settings in Teams.

Add/Remove Users to a Team Channel

We can manage users within a specific channel, enabling us to assign them as either channel owners or members.

The command will return immediately, but the Teams application will not reflect the update immediately. To see the update, you should refresh the members page.

# Get the Group ID of a Team
$GroupId = (Get-Team -DisplayName <TeamDisplayName>).GroupId
#Add user to the Channel in Teams
Add-TeamChannelUser -GroupId $GroupId -DisplayName <ChannelDisplayName> -User <UserEmail>

You can include a role parameter if the user needs to be the channel owner. Refresh the members page to view the changes in the Team application.

Note: Due to technical limitations of private channels, users must first be members of the team to be added as members of a channel. Additionally, to become an owner of a channel, someone must first be a member of that channel.

Similarly, the following command can be used to remove a user from the team channel:

# Get the Group ID of a Team
$GroupId = (Get-Team -DisplayName <TeamDisplayName>).GroupId
#Remove user from the Channel in Teams
Remove-TeamChannelUser -GroupId $GroupId  -DisplayName <ChannelDisplayName> -User <UserEmail>

Remove a Channel from a Team

The following cmdlet deletes a specific channel from a Microsoft Teams team using the PowerShell module.

# Get the Group ID of a Team 
$GroupId = (Get-Team -DisplayName <TeamDisplayName>).GroupId
Remove-TeamChannel -GroupId $GroupId -DisplayName <ChannelDisplayName>

This action will not delete any content from the tabs associated with the channel. Also, only team admins or users with specific permissions are authorized to delete a channel from the team.

Note: This will “soft delete” a channel, which means its contents are not permanently removed immediately. You can restore this within 21 days before it gets permanently deleted. So, any new request to create a channel with the same information will fail for 21 days.

Deleting a standard channel does not delete the channel site. The channel is removed, but the files remain. Deleting a private channel removes the entire site, including all files and conversations.

Finally, disconnect the Microsoft Teams environment from the PowerShell using the following command:

Disconnect-MicrosoftTeams

Conclusion

You can efficiently create and manage Microsoft Teams and channels by utilizing the commands provided, allowing for seamless administration. This also offers the flexibility to manage users within both the teams and individual channels, whether private or shared. This gives you complete control over user roles, permissions, and access.

]]>
https://blogs.perficient.com/2024/12/24/create-and-manage-microsoft-teams-and-channels-with-powershell/feed/ 2 374149
Microsoft 365 Copilot – Shifting the Way We Work https://blogs.perficient.com/2023/03/31/microsoft-365-copilot-shifting-the-way-we-work/ https://blogs.perficient.com/2023/03/31/microsoft-365-copilot-shifting-the-way-we-work/#comments Fri, 31 Mar 2023 19:20:09 +0000 https://blogs.perficient.com/?p=331877

This is a big deal

The tech landscape is always evolving. In the history of computing, there have been three major shifts that completely changed how we view technology and its usefulness to society. Those include:

  1. Graphical User Interfaces
  2. The Internet
  3. Mobile (and social media on mobile i.e. Facebook, Twitter, Instagram and more recently TikTok)

Artificial Intelligence (AI) is the newest shift. Whether you are shopping at a major grocery store chain, keeping up with the latest trends on your favorite social media app, or simply using an iPhone, AI is ubiquitous to your experience.

But these have largely been personal consumer experiences. Now, AI is poised to improve our communication, collaboration and productivity at work. One of the first major forays into this quest is Copilot for Microsoft 365.

Generative AI

Early introductions of AI took the form of an additional surface for search results and customer interactions. More recently, we’ve seen a new category of AI that generates outputs like written creative content, graphic design, audio tracks and more.

Bringing Generative AI in the workplace is poised to streamline more of our day-to-day activities, from live meeting intelligence to personal productivity to smarter marketing campaigns. This has the profound possibility to change how organizations and their workers approach their job duties and processes. That is… if corporations can embrace AI as a competitive advantage vs. working against it.

Related Content: Unleashing the Power of Generative AI: Transforming the Future of Content and Experiences

Generative AI at Work – Microsoft 365 Copilot

On March 16, 2023, Microsoft announced Copilot for Microsoft 365. This new set of functionality seeks to bring the power of next-generation AI to work, providing our experiences in the Microsoft 365 Apps through the power of the Microsoft Graph and AI large language models with your data. This seamless experience seeks to provide a copilot to your work experience and assist with the following:

  • Increase productivity in common apps such as Microsoft Word, PowerPoint and Excel
  • Maximize collaboration through Outlook and Microsoft Teams
  • Simplify event troubleshooting and response for Microsoft 365 administrators
  • Infuse Business Data and best practices into creator tools such as Power Apps, Visual Studio, Dynamics 365 and GitHub
  • Keep a company’s data estate and attack surface secure with AI-driven troubleshooting and faster incident reporting
  • Boost collaboration and communication within Microsoft Viva

Does Copilot do my work for me?

No. Copilot is meant to assist us in our daily tasks. In most cases, it creates a starting point. Copilot is not intended to do the work for you. The goal is to get your preliminary draft started, provide more insights, and make it better.

AI is not perfect. In fact, it is often wrong. This is clear with both ChatGPT interactions and Copilot for Microsoft 365. But end-users can maximize the Copilot-generated outputs with the ability to Delete, Regenerate, Adjust or Keep.

Use Cases

A new tool is simply a shiny object until we get down to the use cases. Proper use cases will decide whether this is going to truly become another monumental shift or a flash in the pan. Copilot use cases are ubiquitous across Microsoft 365, Power Platform and more:

  • Copilot in Word writes, edits, summarizes and creates right alongside people as they work.
  • Copilot in PowerPoint enables the creation process by turning ideas into a designed presentation through natural language commands.
  • Copilot in Excel helps unlock insights, identify trends or create professional-looking data visualizations in a fraction of the time.
  • Copilot in Outlook can help synthesize and manage the inbox to allow more time to be spent on actually communicating.
  • Copilot in Teams makes meetings more productive with real-time summaries and action items directly in the context of the conversation.
  • Business Chat brings together data from across documents, presentations, email, calendar, notes and contacts to help summarize chats, write emails, find key dates or even write a plan based on other project files.
  • Copilot in Power Platform will help developers of all skill levels accelerate and streamline development with low-code tools with the introduction of two new capabilities within Power Apps and Power Virtual Agents.
  • Copilot for Security will aggregate Microsoft Sentinel security data and correlate alerts from virtually any source with intelligent security information and event management (SIEM); prevent and detect attacks across your identities, apps, email, data, and cloud apps with extended detection and response (XDR) via Microsoft Defender and help mitigate threats to devices, protect corporate data, and improve compliance across all cloud and on-premises endpoints with Microsoft Intune.
  • Copilot for Sales promises to move deals forward, provide deeper customer intelligence and enrich the customer experience through integrations with Viva Sales, Power Virtual Agents, Customer Insights, and Dynamics 365 (Marketing, Customer Service, Supply Chain Management and Business Central)
  • More to come including Dynamics/CRM 365, Viva, Loop, Nuance, and more…

What about Ethics and AI?

Copilot follows the larger Microsoft privacy rules and regulations. Microsoft 365 Copilot does not use customer data – including prompts – to train or improve its large language models. Microsoft believes the customers’ data is their data. Existing Microsoft guarantees for enterprise and commercial data persist and continue. This is especially important in this new era of AI. Follow this link to review Microsoft’s privacy policy and service documentation for more information.

Microsoft recently revised its responsible AI standards and general requirements. See this link for the for details. Microsoft summarizes it’s stance as follows:

Microsoft is committed to creating responsible AI by design. Our work is guided by a core set of principles: fairness, reliability and safety, privacy and security, inclusiveness, transparency, and accountability. We are helping our customers use our AI products responsibly, sharing our learnings, and building trust-based partnerships. For these new services, we provide our customers with information about the intended uses, capabilities, and limitations of our AI platform service, so they have the knowledge necessary to make responsible deployment choices.
Microsoft Responsible AI Standard v2 General Requirements

Copilot Availability

Copilot comes in a few different flavors. Each of these variations have their town timeline.

  • Copilot for GitHub – available now.
  • Copilot for Power Apps – currently available in the United States and English language by signup
  • Copilot for Microsoft 365 – currently testing Microsoft 365 Copilot with 20 customers, including 8 in Fortune 500 enterprises. We will be expanding these previews to customers more broadly in the coming months and will share more on new controls for IT admins so that they can plan with confidence to enable Copilot across their organizations…We will share more about pricing and details in the coming months
  • Copilot for Sales – Copilot for Viva Sales is available now. Deeper feature for Dynamics 365 Customer Service are in limited preview and waitlisted. Additional features mentioned in this article are also in preview.
  • Copilot for Security – Microsoft Security Copilot is currently in preview and not yet generally available. Sign up for Microsoft Security updates to learn about product announcements, security insights, and upcoming events.

Ready to Reimagine Your Employee Experience?

Our dedicated Microsoft Modern Work practice brings the best expertise in the industry. From M365 Strategies to Intelligent Intranet to Microsoft Teams to Microsoft Viva, our consultants are here to ensure your success.

As a designated Modern Work Microsoft Solutions Partner and Viva Early Adopter, our Microsoft Partner Advisory Council and Partner Program contributions along with our 20+ years of delivering employee experiences to our clients means we seek to build the best strategy for your organization.

]]>
https://blogs.perficient.com/2023/03/31/microsoft-365-copilot-shifting-the-way-we-work/feed/ 1 331877
Microsoft Teams: Current Landscape for Teams Tenant Migration https://blogs.perficient.com/2023/03/27/microsoft-teams-current-landscape-for-teams-tenant-migration/ https://blogs.perficient.com/2023/03/27/microsoft-teams-current-landscape-for-teams-tenant-migration/#respond Mon, 27 Mar 2023 18:00:09 +0000 https://blogs.perficient.com/?p=247373

Many organizations are reaching a level of maturity with their Microsoft Teams adoption.   Mergers, acquisitions, divestitures, or even regulatory requirements can create a need for Microsoft Teams tenant consolidation or divestiture.  While the situation is changing quickly the current state of migration scenarios and tools for Teams migration between Tenants presents a number of challenges.

Microsoft Teams Architecture

A Microsoft Team relies on the following services, at a minimum:

  • a Microsoft 365 Group (which are Azure AD groups).  Membership and ownership live here.
  • an Exchange Online mailbox associated to the Microsoft 365 Group. Some emails sent to the Microsoft Team are stored here as well as channel conversation history (in a hidden folder for compliance and discovery).
  • a SharePoint Online site.  A SharePoint document library provides the file storage location for Team channels. Channel specific emails go to the document library folder for that channel.
  • Azure Chat Service supporting the channel conversations (compliance records are stored in the associated Exchange Online mailbox, but the “live” chat information is in the Azure Chat Service).
  • Individual user mailboxes are used to store chats – that is, chats between users (1 to 1 or 1 to many) that don’t occur in a Team channel.

In addition, a Team may have one or more Private Channels or Shared Channels.  This article will not cover the details of Shared Channels but there are similarities with Private Channels.  A Private Channel has the following supporting services:

  • Membership is a subset of parent Team membership.
  • A separate SharePoint Online site from the Team’s parent site.  Membership of this site is equivalent to membership of the private channel.
  • A “group” chat which includes all the members of the private channel.  Because it is actually a group chat rather than a channel conversation the conversation compliance records are stores in each member’s mailbox.

If administratively allowed, team members and owners can readily add tabs to a team channel for a wide range of Microsoft 365, Azure, and third-party services.  Examples include Planner, Power BI, Azure DevOps, OneNote notebooks, JIRA, StackOverflow, Flow, Trello, etc.

Team Tenant Moves

Compelling and Complicated

The integrations with Microsoft 365, Azure, and third-party services make Microsoft Teams usage compelling.  As a Microsoft Team member, you and your team can extend your Microsoft Team into a supercharged collaboration environment and productivity boosting dashboard, adding tabs for a number of Microsoft 365, Azure, and third-party applications.  For many adopters, Microsoft Teams becomes the primary user interface used during a large part of the workday.  However, this level of integration with and reliance on so many services makes the migration of a Microsoft Team to another Microsoft 365 Tenant a complicated challenge for migration personnel and for migration tool builders.

Common Microsoft Team Migration Experience

At this time, Microsoft does not provide a migration tool or experience for Teams.  However, several third parties have developed or adapted tools to provide migration solutions. Community created PowerShell scripts also can help in certain scenarios. In every case, at this time, the migration experience is less than a full fidelity experience.

Causes of the limitations:

  • limitations of the underlying APIs for Teams, especially for retrieval and replay of Team channel conversation history
  • varying storage locations for the data
  • varying underlying APIs for the services/data represented in the tabs that may have been added to a Team

Commonly, most solutions do migrate the following (each migration solution will, of course, have subtle differences):

  • underlying Group/Team membership (watch out for Dynamic Groups, however, which may be migrated as static groups) for any type of Team (Public, Private, or Organization wide)
  • Team channels and files (via the underlying SharePoint site)
  • Team channel chat history (although often in a truncated and/or archive format)

Common Microsoft Team Migration Experience Gaps

Common gaps in the migration experience will be

  • Team channel conversation history migration and representation in the target tenant (API limitation).  The history may be present but not in its full original form.  Some tools are now able to restore a portion of the conversation history in a semblance of its original form.
  • No migration of likes/reactions (API limitation) (this limitation also affects Discovery and Compliance scenarios)
  • No migration of private channel chat history (because this data is contained in user mailboxes and may be migrated with the mailbox but often that migration will have a separate timeline and effort from the Teams migration)
  • No migration of user specific settings
  • No migration or limited migration of Team tabs – Tabs such as Planner, Power BI, OneNote, and many others require third-party or manual solutions.

Conclusion

Microsoft Teams provides a transformational collaboration experience for today’s teams and their projects.  Teams provides the integration glue that holds together so much collaborative goodness, but the result is a complex Teams Tenant migration story.  The nature of Teams integrations and extension means that there are likely to be gaps in the migration experience for the foreseeable future, especially for extensively used Teams that take advantage of a full range of Teams capabilities.  That’s understandable, but we should also collectively encourage Microsoft to provide better tenant portability for the core Teams workloads.  In the meantime, Perficient’s Microsoft consultants have extensive experience with native and third-party migration tools in Microsoft Teams Tenant to Tenant migration scenarios and would be glad to assist with identifying the right solution for your organization’s migration challenges.

]]>
https://blogs.perficient.com/2023/03/27/microsoft-teams-current-landscape-for-teams-tenant-migration/feed/ 0 247373
The New Microsoft Teams for Desktop is Here https://blogs.perficient.com/2023/03/27/the-new-microsoft-teams-for-desktop-is-here/ https://blogs.perficient.com/2023/03/27/the-new-microsoft-teams-for-desktop-is-here/#respond Mon, 27 Mar 2023 16:58:48 +0000 https://blogs.perficient.com/?p=331512

Microsoft introduces the next chapter of Microsoft Teams

Today, March 27, 2023, Microsoft announced the New Microsoft Teams desktop client. This new version of Teams promises to address customer challenges regarding ease of use, reliability, and overall performance. It will be available via Public Preview in March 2023 and generally available later this year.

NOTE: These updates are for desktop only. This update does not affect the Teams mobile client. No major changes are planned for the mobile client at this point.

Read more below on what the benefits are and who the best candidates are for the new Microsoft teams.

End-User Benefits: Speed & Performance

The new Microsoft Teams is built for speed and collaboration. Improvements to the user interface will allow for improved switching between accounts and tenants. The new version will also unlock more speed and performance benefits for end users. These benefits will include the following:

  • Speed
    • 3x faster installation times
    • 2x faster app launch
    • 2x faster meeting join times
    • 7x faster chat and channel switching
  • Performance
    • 50% less memory usage
    • 70% less disk space

IT Benefits: Security & Management Enhancements

IT administrator benefits enable more security and manageability enhancements for IT administrators such as:

  • Improved meeting quality
  • Partial data model to improve screen rendering
  • Streamlined app installation through Microsoft Intune and MSIX
  • Reduced network and disk space usage
  • Hardened security, including Trusted Types and stronger Content Security Policy,

A Bit of Caution for Heavy Teams Users

Although this newer, zippier version of Microsoft Teams brings tons of benefits, there are also some drawbacks worth calling out. Currently, the new Microsoft Teams has not reached feature parity with the current desktop client.

While first-party apps such as SharePoint, Office, Microsoft Viva and others work as expected, some third-party and custom apps may not. These will be mitigated on a case-by-case basis, however if you organization has custom SPFx web parts and apps in Teams tabs, these will not work immediate and will need to be investigated. Also, organizations using Teams App templates should also defer this update for later.

Ideal Candidates for the New Microsoft Teams

The best candidates for the new Microsoft Teams desktop client are those using Microsoft Terms for basic collaboration scenarios such as chat and meetings. Organizations using mostly windows machines will have a better experience (initially) as support for Mac OS is coming soon. Supported versions of Windows include Windows 10: version 10.0.18800 or higher and Windows 11: version 22000.856 or higher.

How Do I get Started?

The Microsoft Teams will be available via Publix Preview in March 2023, Targeted Release in April 2023, and General Availability later this year. Once enabled within the Microsoft Teams update management policy settings, users may switch to the new experience from a toggle in the Teams user interface.  They may also switch back via the same toggle as long as the app has not been abled by default.

Microsoft has provided tons of resources for getting started on the journey to the new Teams Client. These resources range from feedback and roadmap information to technical, end-user, and adoption considerations. Check out the list of getting started resources below:

Ready to Reimagine Your Employee Experience?

Our dedicated Microsoft Modern Work practice brings the best expertise in the industry. From M365 Strategies to Intelligent Intranet to Microsoft Teams to Microsoft Viva, our consultants are here to ensure your success.

As a designated Modern Work Microsoft Solutions Partner and Viva Early Adopter, our Microsoft Partner Advisory Council and Partner Program contributions along with our 20+ years of delivering employee experiences to our clients means we seek to build the best strategy for your organization.

]]>
https://blogs.perficient.com/2023/03/27/the-new-microsoft-teams-for-desktop-is-here/feed/ 0 331512
Perficient Earns Custom Solutions for Microsoft Teams Specialization https://blogs.perficient.com/2022/11/09/perficient-earns-custom-solutions-for-microsoft-teams-specialization/ https://blogs.perficient.com/2022/11/09/perficient-earns-custom-solutions-for-microsoft-teams-specialization/#respond Wed, 09 Nov 2022 16:52:27 +0000 https://blogs.perficient.com/?p=321522

As the shift to remote and hybrid work remains ever-present, countless organizations count on Microsoft Teams for business communication. While Microsoft’s powerful collaboration tools have benefited these organizations, there is a growing need for custom business application integrations to further meet connectivity and productivity demands.

Custom Solutions for Microsoft Teams Specialization Badge

We are proud to announce that Perficient has achieved the Custom Solutions for Microsoft Teams Specialization, formally recognizing Perficient as a leading partner in tailored Microsoft Teams solutions.

“Customizing Microsoft Teams allows our customers to meet their unique business needs and integrate applications with the M365 ecosystem,” says Steve Ottenad, Modern Work Practice Architect, “This specialization highlights our commitment to delivering comprehensive, well-executed solutions on the Microsoft Teams platform.”

Award-winning Success Delivering Tailored Teams Solutions

Our work at hospice care provider VITAS earned us a finalist spot in last year’s Microsoft Healthcare Partner of the Year award. We helped VITAS transform its care team collaboration with a tailored Microsoft Teams and Power Apps solution. The solution improved the continuity of care by avoiding after-hours intervention, restructured workflows for patient care teams, and reduced care costs.

Learn more: VITAS Healthcare: Transforming Patient Care During a Pandemic

“Our continued effort to keep our team trained and delivering custom solutions on top of the entire M365 platform, especially Teams and SharePoint, has allowed Perficient to provide tailor-made applications to our customers,” continues Ottenad.

Trusting our Experts for Perficient’s own Digital Transformation

Perficient’s colleagues also benefit from the customization of Microsoft Teams that our employee experience experts provide for our clients. Last year, Perficient colleagues were introduced to a sleek, modern, redesigned intranet experience that leverages Viva Connections, Microsoft Teams, Power Platform, SharePoint, and other integrations across the Microsoft Suite.

“Customization is always influenced by the landscape we work in,” emphasizes Ottenad, “Striking the balance between out-of-the-box functionality and intelligent, efficient, maintainable customization is where our team really shines.”

Learn more: Reimagining Our Employee Experience With a New Intranet

A Trusted Microsoft Partner

Having previously earned Microsoft Specializations in Adoption and Change Management, Modernization of Web Applications to Azure, and Microsoft Security, this specialization further strengthens our award-winning Microsoft Solutions Partnership. It demonstrates our expertise in delivering solutions across the Microsoft Cloud.

Ottenad concludes, “Whether integrating 3rd party applications or building net-new software to solve unique problems, our group has developed a skillset that allows us to use the M365 ecosystem to its fullest and ensure that the solutions we deliver are effective, maintainable, and secure.”

Why Perficient?

Perficient is committed to meeting the demands of customers’ cloud needs with highly skilled and specialized partnerships. Our dedicated Microsoft Modern Work practice brings the best expertise in the industry. From Intelligent Intranet to Microsoft Teams to Microsoft Viva, our consultants are here to ensure your success.

Ready to modernize your workplace? Contact our team.

]]>
https://blogs.perficient.com/2022/11/09/perficient-earns-custom-solutions-for-microsoft-teams-specialization/feed/ 0 321522
An Introduction of Azure Sentinel https://blogs.perficient.com/2022/09/07/an-introduction-of-azure-sentinel/ https://blogs.perficient.com/2022/09/07/an-introduction-of-azure-sentinel/#respond Wed, 07 Sep 2022 14:30:57 +0000 https://blogs.perficient.com/?p=317781

An Introduction of Azure Sentinel

Microsoft Sentinel is a solution for a variety of issues including intelligence analysis, detecting uncovered threats, investigating suspicious activity, enterprising monitoring, and rapid response. Sentinel is a Security Information and Event Management (SIEM) and Security Orchestration, Automation, and Response (SOAR) service in the cloud.

Today, I will discuss Azure Sentinel’s benefits, how it differs from Microsoft Defender for Cloud (formerly Azure Security Center), how to use it to trigger an alert when a malicious incident has occurred, and forward the notification to a specific Microsoft Teams channel.

Understanding the Risk

Today’s organizations are moving toward multi-clouds like GCP, AWS, Azure, and On-Premesis. People currently work outside the company network, using unknown websites and suspicious devices. This leaves your organization vulnerable to attacks by hackers. Your priority should be protecting your investment by collecting data, detecting threats, investigating threats, and responding to the threat accordingly. Therefore, you need a security manager that can keep eye on everything. This is where Azure Sentinel can step in.

Azure Sentinel 1

 

The Difference Between Azure Sentinel & Microsoft Defender for Cloud

Azure Sentinel 2

Both Azure Sentinel and Microsoft Defender for Cloud are offered by Microsoft. However, Microsoft Defender for Cloud mainly focuses on detecting security issues, generating alerts, misconfiguration, and lack of permission. These alerts would be further utilized by Azure Sentinel to investigate and respond accordingly.

To begin your Azure subscription, you’ll first need to create a free account here.

You will also need to familiarize yourself with some definitions before proceeding, such as:

  • Resource Group – a container that contains related resources for an Azure solution.
  • Log Analytics workspaces – used to store logs and data from Azure.
  • Storage accounts – used to share data and logs generated from Log Analytics.
  • Permission– Contributor or reader permissions on the resource group.

 

How to Set Up Sentinel for a Storage Account

Follow these six steps to set up Azure Sentinel in a storage account.

1. Create a Resource Group

First, login to Azure portal and search “Resource group” in the search bar. Then, select “create.”

Next, enter the following in these three values:

  • In subscription, select “Free Trial.”
  • Resource group: I created a resource group called “rahulresource” as an example. You can create your own name based on your Project name.
  • Region: I have selected “(US) East US.”

Then, select “Review + create.”

Azure Sentinel 3

 

2. Create a Workspace:

Search for “Log Analytics Workspace” and select “create.” Then, choose “subscription” and select the existing resource group. Provide a name to the new log analytics. For example, I named my workspace “testinstance.” Finally, select “review + create.”

Azure Sentinel 4

 

3. Create a Storage Account

Search for “storage accounts” in the search bar and select “create.” Then, choose the existing resource group. Add your unique storage account name. For example, I added “rahulstorage9.” Then, select “standard” for “performance” and “redundancy” for “locally-redundant storage (LRS)”.

Next, set “default” as the configuration for the tabs “Advance,” “Networking,” “Data protection,” “Encryption,” and “Tags.”

Finally, select “Review + create.”

Azure Sentinel 5

 

4. Enabling Microsoft Sentinel

Search for “Microsoft Sentinel” and select it and the workspace you created before, such as the “testinstance” I created. Then, find “data connectors” in the left portal menu.

Next, search for the “Azure Storage Account,” and open the “connector” page. Inside the Azure Storage Account, go to the “diagnostic setting” on the left menu. Then, select “+ Add diagnostic setting” and type a diagnostic setting name. Next, under the “destination” details, choose “send to log analytics workspace.”

Select the log analytics as a “testinstance (eastus).” And under “metrics,” check the box for “transaction” and click “save.”

Azure Sentinel 6

 

 

5. Hunting in Sentinel

In the left portal menu in Sentinel, find and choose “hunting.” Then click on “+ New Query” and enter the following into the values:

  • Add “Monitor Azure Storage Account” into “name.”
  • In “custom query,” add the query below:

 

AzureActivity

| where Properties has “Microsoft.Storage/storageAccounts/listKeys/action”

| extend WhoDidIt = Caller, StorageAccountName = tostring(parse_json(Properties).resource)

| project WhoDidIt, StorageAccountName, ResourceGroup, _ResourceId, CallerIpAddress, EventSubmissionTimestamp

 

Then, click on “Create.”

Azure Sentinel 7

 

6. Deploying the Playbook to Post a Message on Microsoft Teams

You’ll create a playbook using a Microsoft template by clicking here. Then, enter the name of your playbook. For example, I named mine “PostMessageTeams-OnAlert.” Next, click “review + create.”

Azure Sentinel 8

Within the Microsoft Sentinel, navigate to “Hunting” and “Open live stream.” Create an analytics rule in the “General” tab and enter the “Name.” Finally, choose “medium” as the severity.

Azure Sentinel 9

 

 

In the “Set rule logic” tab, you’ll add the entity mapping as you see below:

a) Account > Name > WhoDidIt

b) IP > Address > CallerIPAddress

c) Azure resource > ResourceId > _ResourceId

  • In the “Incident settings” tab, enable the “Alert grouping” option.
  • In the “Automated response” tab, select “PostMessageTeams” as an “Alert automation playbook.”
  • Click “Review + create.”

Azure Sentinel 10

 

Azure Sentinel 11

Azure Sentinel 12

To Conclude…

I have performed a proof of concept on Azure Sentinel that will trigger an alert when a malicious incident occurs in an Azure Storage Account and forwarded it to a specific Microsoft Teams channel.

Perficient is uniquely positioned to serve our consumers that need assistance in these areas. Our experts will partner with you to understand what your specific business needs and goals are and develop a map to change your company’s trajectory. Our experts will be with you every step of the way. For more questions, contact our experts today.

]]>
https://blogs.perficient.com/2022/09/07/an-introduction-of-azure-sentinel/feed/ 0 317781
Using Microsoft Teams: Utilize Chats, Meeting Chats, & Posts https://blogs.perficient.com/2022/02/17/using-microsoft-teams-utilize-chats-meeting-chats-posts/ https://blogs.perficient.com/2022/02/17/using-microsoft-teams-utilize-chats-meeting-chats-posts/#respond Thu, 17 Feb 2022 13:45:11 +0000 https://blogs.perficient.com/?p=304903

This blog is the third and final in a three-part series tackling how to set up and use Microsoft Teams for a project.

Chats, Meeting Chats, and Channel Posts are all excellent methods of communication within Microsoft Teams. However, there is often confusion amongst project teams of when it is appropriate to use each feature. Refer to the following guidelines for using Chats, Meeting Chats, & Channel Posts to maximize your team’s communication and effectiveness.

Chats

Chats can be 1:1 with another Teams user or with a group of users. They are best used for messages that don’t need to be seen by the full project & client teams. They are for informal, ad hoc conversations and good for one-off confirmations or follow-ups.

Chats

Meeting Chats

You can access the Chat for a meeting by clicking on the meeting instance in the Calendar tab, and selecting “Chat with participants”. Meeting chats are where you should post meeting agendas and notes. You can also list out and follow up on action items discussed in the meeting.

Meeting Chats

Channel Posts

Teams Channel posts are best for structured communication and file sharing. They are traceable and visible to the entire team. Use a Teams Channel post for formalized requests and information that affects the project or the client. For more information on how to write a successful Teams Channel post, check out this blog.

Channel Posts

Catch up on the Using Microsoft Teams series….

Looking for more tips for using Microsoft Teams for your projects? Check out the Using Microsoft Teams blog series from the beginning!

]]>
https://blogs.perficient.com/2022/02/17/using-microsoft-teams-utilize-chats-meeting-chats-posts/feed/ 0 304903
Using Microsoft Teams: Set Up and Organize Teams Channels for Your Project https://blogs.perficient.com/2022/02/17/using-microsoft-teams-set-up-and-organize-channels-for-your-project/ https://blogs.perficient.com/2022/02/17/using-microsoft-teams-set-up-and-organize-channels-for-your-project/#respond Thu, 17 Feb 2022 13:45:09 +0000 https://blogs.perficient.com/?p=304888

This blog is the first in a three-part series tackling how to set up and use Microsoft Teams for a project.

Maintaining good communication is crucial to project success. One of the best tools to facilitate regular communication amongst your project team is Microsoft Teams. In this post, we’ll cover a useful way to set up your Teams channels using a project RACI Matrix.

1. Establish a Project RACI Matrix

You can use a RACI Matrix to establish the Teams channel structure. But what is a RACI?

RACI stands for Responsible, Accountable, Consulted, Informed. The RACI Matrix maps project workstreams and deliverables to roles within the project, on both the project team and the client team. A RACI meeting should be held with the full team at the start of the project, during which the team uses the RACI terms to assign project duties to each role on the team.

Each workstream in the RACI Matrix should correlate to a Microsoft Teams channel. The number of channels needed depends on the scope of the project. Team members can refer back to the RACI Matrix when choosing a channel to post in.

Usually, each Teams channel is owned by one person on the project team and one person on the client team. The owners monitor the channel and are the point of escalation for that channel’s posts.

RACI Matric Example

Above is a simplified RACI Matrix, to show how roles are assigned. For more information on creating and using a RACI Matrix, click this link.

2. Introduce Each Teams Channel

You can set up a Wiki in each Teams channel in order to store important information & FAQs related to the channel’s workstream. The channel’s owners and purpose should be stored in the Wiki, which helps focus the messages held in that channel. The first post in any channel should be a welcome message from the Project Manager that contains this information as well.

Channel Welcome Post

3. Add Channels Where Needed

You may notice the need for a new channel that was not covered in the RACI Matrix. For example, setting up a ‘General’ channel is helpful for high-level project announcements and posts that don’t fit in other channels.

If the project team decides there is need for a new channel at some point in the project, a new one can be created. This should be brought up in a client leadership meeting and confirmed by the client. This new channel should follow the same format as the other channels, with owners, a channel purpose, and a welcome message.

Next Up in the Using Microsoft Teams series…

Looking to optimize your project’s communication in Microsoft Teams? Check out this blog for tips on writing the most effective Teams posts.

]]>
https://blogs.perficient.com/2022/02/17/using-microsoft-teams-set-up-and-organize-channels-for-your-project/feed/ 0 304888
Using Microsoft Teams: Write Effective Teams Posts https://blogs.perficient.com/2022/02/17/using-microsoft-teams-write-effective-teams-posts/ https://blogs.perficient.com/2022/02/17/using-microsoft-teams-write-effective-teams-posts/#respond Thu, 17 Feb 2022 13:45:02 +0000 https://blogs.perficient.com/?p=304898

This blog is the second in a three-part series tackling how to set up and use Microsoft Teams for a project.

So you’ve posted a message in Teams and you’re asking yourself, why hasn’t anyone responded? It might be that your messaging isn’t clear, or the right people don’t even know that you’re addressing them. In this post, we’ll cover how to craft an efficient Teams post that elicits the right responses and helps move your project along.

Business Writing 101

When writing a Teams post, start with this question: What’s in it for the reader?

Think about the 3 W’s:

1. Why am I writing this post?

Make sure your post makes sense for the Teams communication method you’ve chosen – should it be posted in a formal Teams channel, or would it be better suited for a Teams Direct Message?

2. Who needs to read the post and take action?

Tag the team members who need to know about your post, they might be stakeholders or decision-makers for the issue. You’ll want to use Teams Tags to address a larger audience, like the full project team.

3. When does this topic need to be addressed?

If the topic needs to be addressed ASAP or is critical to the health of your project, mark the post as important.

Formatting Your Post: Subject Line & Description

Your Teams post needs both a Subject Line and a Description to be most successful.

Subject Line:

Your subject line should be short, informative, and to-the-point. The reader should have a good idea of what the post is about just by the subject line. A concise subject line also makes the post easier to find when searching in Teams. Include dates when appropriate, like if you’re requesting a decision or feedback.

Description:

The description is the real meat of your post. Try to be brief – you should be able to get your point across in 4 sentences or less. Assume the reader will skim your post and write it that way. If your post contains a question or recommendation, bold/italicize it to stand out, and directly address the team members that need to take action. Incorporate bullet points where possible to highlight the most important information.

Ineffective v. Effective Teams Posts

Let’s take a look at an example of an ineffective and effective Teams posts.

Ineffective:

Ineffective

This post is too wordy and lacks any formatting, it’s likely that no one takes action on it.

Effective:

Effective

By changing the formatting and flow of the post, the tagged team member is aware of the situation and knows what is requested of them, so they can take immediate action.

Best Practices

  • If you refer to specific files in your post, make sure to include a link to them – make it as easy as possible for the reader (use hyperlinked text where possible for this).
  • CC members of your team that are working with you on the issue
  • If you still haven’t gotten any responses after a few hours/days, comment on the post to follow up with those you tagged.
  • Once the issue has been resolved, comment on the post to notify all that the issue is closed.

Next Up in the Using Microsoft Teams series…

Want to post in Teams, but sure where your content is most appropriate? Check out this post for help with utilizing Chats, Meeting Chats, & Posts for your messages.

]]>
https://blogs.perficient.com/2022/02/17/using-microsoft-teams-write-effective-teams-posts/feed/ 0 304898
Configure your Microsoft Teams Integration with Amazon Connect through PACE https://blogs.perficient.com/2022/02/07/configure-your-microsoft-teams-integration-with-amazon-connect-through-pace/ https://blogs.perficient.com/2022/02/07/configure-your-microsoft-teams-integration-with-amazon-connect-through-pace/#respond Mon, 07 Feb 2022 15:00:58 +0000 https://blogs.perficient.com/?p=304331

Today, many businesses depend on Microsoft Teams for internal communications and Amazon Connect for their contact center, making it challenging for agents to accept queued calls and simultaneously answer internal calls in Teams. Suppose there is no status synchronization between the two solutions. In that case, this behavior could significantly impact several levels, such as the quality of service, as some calls are abandoned and not answered. Additionally, it could affect the response rate, which is an important KPI for contact center supervisors. And when it comes to transfers, the agents would also need to look for available resources in Teams to find out the best way to transfer the calls to them. For sure, this might not be how contact center agents imagine their workday.

Configure your MS Teams status sync with PACE

Perficient’s Amazon Connect Experience (PACE) supervisors and agents don’t need to worry about this as they can easily integrate Teams and keep a consistent presence on both platforms. Configuring the MS Teams integration in PACE enables the syncing of statuses from Microsoft Teams to Amazon Connect in near real-time. Agents can simply enable this integration as each agent can choose either to enable or disable it with a click directly from the Agent Console. With this functionality they also retain the level of flexibility, as they don’t need to involve supervisors or administrators to configure this for them multiple times per day.

Pace + Teams1

Connect customers with your MS Teams contacts

Another feature I find super helpful is transferring a call to an MS Teams contact within your organization. During the active call on the Agent Console, the agent can easily search for contacts either by their name or tag. Tags are a great way to categorize people by their team and expertise. So, for example, you can organize all people from the Sales department by a simple sales tag.

External transfer to an MS Teams contact

External transfer to an MS Teams contact

In some cases, an agent might try to transfer a call to a contact who is busy on another call or away from his desk. With PACE, the agent can see the Teams presence indicator of the contact to avoid this scenario. Moreover, the presence indicator also helps provide a better customer experience by minimizing agents’ hold times.

In either case, for those who like to experiment, here is what happens when you attempt such transfer. First , a warning message displays asking for your approval to proceed. After that, you can continue with the transfer if you would like to, but the system has informed you of the possible outcome.

Warning message when transferring to unavailable contacts

Warning message when transferring to unavailable contacts

Microsoft Teams Integration setup

Administrators must only configure a few Azure AD settings specific to the environment and select the Enable Teams Status Sync checkbox to allow status syncing. Voila! Just a couple of configuration values and your journey with MS Teams and PACE is ready to begin.

Enabling MS Teams integration

Enabling MS Teams integration

But wait, there is more

We continue to listen to your feedback, and we’re constantly working on adding new features. For example, our roadmap includes MS Teams Chat-Bots, which allow Teams users to trigger chats directly from Teams without opening any browser or searching the company website. We’re also adding presence sync from PACE to MS Teams and more.

If you’re interested in MS Teams integration with PACE, or Amazon Connect in general, we can help. At Perficient, we are an APN Advanced Consulting Partner for Amazon Connect which gives us a unique set of skills to accelerate your cloud, agent, and customer experience.

Perficient takes pride in using a personal approach with enterprise clients to help transform and modernize their contact center and CRM experience with platforms like Amazon Connect.

For more information on how Perficient can help you get the most out of MS Teams integration with PACE or Amazon Connect, please contact us here.

]]>
https://blogs.perficient.com/2022/02/07/configure-your-microsoft-teams-integration-with-amazon-connect-through-pace/feed/ 0 304331
12 Microsoft Ignite Announcements (Fall 2021) https://blogs.perficient.com/2021/11/05/10-microsoft-ignite-announcements-fall-2021/ https://blogs.perficient.com/2021/11/05/10-microsoft-ignite-announcements-fall-2021/#respond Fri, 05 Nov 2021 20:23:47 +0000 https://blogs.perficient.com/?p=299973

November 2-4 marked the second Ignite of 2021, bringing so many announcements and captivating the Microsoft community with a flood of “new”. From seemingly small quality of life changes to holistic new apps and experiences, this fall edition of Microsoft Ignite 2021 introduced plenty to talk about!

Sifting through the mass of excitement, I’ve settled on this list that is by no means definitive of all the announcements from the Fall Ignite. Instead, these are some highlights worth calling out.

Here are 12 announcements that caught my eye:

1. Microsoft Viva Suite

Since the announcement of Microsoft Viva, the new employee experience suite, the Microsoft community has had two key questions: “When can I have it?” and “How much will it cost?”. The hard-working minds of Microsoft Viva released pricing in two flavors: Per app pricing with Viva Topics, Viva Learning and Viva Insights at a cost of $4/user/month. And Viva Suite, which gathers all the Viva apps into one cohesive package for $9/user/month for the next year. Note: Viva Suite will have an ongoing price of $12/user/month after the first year of availability. See this article for more details.

Microsoft Viva: Latest innovations and roadmap for the new digital employee experience

2. Viva Topics become ubiquitous in M365

The usage of Viva Topics started as a very SharePoint-y feature, bringing together collective knowledge within an enterprise through topic computing. From Ignite announcements, Microsoft now promotes the usage of Viva Topics throughout the M365 user experience including SharePoint, Microsoft Teams, Yammer, Microsoft Search, People Cards, and more.

What’s New and Next in Microsoft Viva Topics

3. Microsoft Loop

Remember Fluid Components and the entire Fluid Framework? They’ve now been repackaged into an entire app now called Microsoft Loop. Loop is the next step in simultaneous collaboration. An interactive canvas experience similar to use cases in Mural, Miro, and Lucid, Loop helps organizations collaborate in real time through workspaces, pages and components surfaced through Microsoft Teams, Outlook and other apps. See this link for more.

4. Microsoft Search Enhancements

Microsoft Search is growing in a big way. It’s bringing more connectors and content to the Modern Workplace with wider use of Answers (bookmarks, acronyms, Q&A, and now Topics) as well as the use of the new Turing AI model for knowledge answers. Also exciting are new connectors for Jira and Confluence along with the expansion of Service Now search with catalogs and tickets. SharePoint fans will enjoy the new abilities for modifying search pages and tabs alongside integrations with human resource management systems (HRMS) to enrich employee profiles. This video from the MS Search Team covers lots of ground on the subject.

Make the most of Microsoft Search

5. Shared Channels in Microsoft Teams via Teams Connect

Private Channels in Microsoft Teams have been hit and miss for a lot of our clients. However, the need to collaborate with partners, clients and other associated parties is more vital than ever. Teams Connect will make it easier to work with parties outside your organization while providing the security mechanisms to ensure a proper and company-compliant governance approach.

7. Lots more updates for Microsoft Teams

The sheer number of Microsoft Teams updates is staggering. The wide swath starts with quality of life enhancements such as the ability to hide (or pin) your own video, see the order of raised hands, muting notifications. Further updates will improve features for larger meetings and webinars. Check out the official blog for a more comprehensive list of updates for Microsoft Teams.

8. New Hybrid SharePoint Connector for Microsoft Search

One of the most overlooked items in the Microsoft Search updates was mention of a new connector for SharePoint Server. This connector is based on the data gateway platform, more synonymous with Power BI and Power Platform. As many customers are either reluctant to put content into the cloud or have compliance needs that necessitate keeping their data, on-premises, this update will hopefully ease the pain of information sprawl.

9. Co-authoring in Power Apps Studio

The dreaded limitation of one app per person is hopefully coming to an end soon. According to Microsoft, “Two or more makers can load a Canvas app in Power Apps Studio, make independent changes, and save to merge those changes with other makers. Merges are semantically aware of the app structure, making for a much cleaner result.” This is classified as an “experimental” feature, but all fingers are crossed on this one. Check out the update this highly anticipated feature here.

GIF of adding author in Power Apps

10. More Power Platform Updates

The Power Platform updates were wide and sprawling from Microsoft Teams to Dynamics. Deeper integrations with Microsoft Teams will further the use of Power Automate and Power Virtual Agents as well as improvements to the Power BI app. Pay-as-you-go app models will be an interesting development and should be something to watch. Other improvements such as improved Azure, GitHub and Power FX updates will also be interesting to watch. Check out the Power Platform blog for more updates from Ignite.

11. Mesh for Microsoft Teams

Microsoft Mesh is a new experience within Microsoft teams with the goal of reducing meeting fatigue by using personal avatars instead of meeting video. This feature enables users to interact in both 2D and 3D immersive experiences. Microsoft Mesh allows people to experience meetings, whether it’s large onboarding sessions or on-on-one catchups, in an entirely new, less stressful way.

screenshot of meeting gallery with mesh avatars

12. New Microsoft Customer Experience Platform

Microsoft’s new Customer Experience Platform brings together the rich toolset of Dynamics 365 with the power of Azure AI into a new customer engagement solution. This evolution of marketing features for Dynamics 365 unifies its consent-enabled Customer Data Platform with expanded business-to-business tools. Modern marketing organizations can gain greater understanding of customer intents and behaviors alongside new insights. See this link for more details.

BONUS! Context IQ

More than a text editor, Context IQ is an AI-powered experience built into the M365 suite that helps with creating more meaningful content, posts, and messages in apps such as Microsoft Teams, Dynamics, and Loop. The premise is simple: get communications right the first time with the ability to attach/insert files for sharing, enter data objects and components from other apps (see Loop above), find available calendar times, tag colleagues in a file, and more. Check out this link for more information.

Want to take in all the lavish goodies of Ignite Fall 2021? Take a deep dive down the rabbit hole through the Microsoft Ignite Book of News. Whether you follow Microsoft 365, Azure, Dynamics 365, Security, Power Platform, AI or a combination, this Book of News captures all the announcements this week and will help navigate the sea of updates. Check it out here.

Why Perficient?

Our dedicated Microsoft Modern Work practice brings the best expertise in the industry. Our Microsoft Partner Advisory Council and Partner Program contributions along with our 20+ years of delivering employee experiences to our clients means we seek to build the best strategy for your organization. From Intelligent Intranet to Microsoft Teams to Microsoft Viva, our consultants are here to ensure your success.

Contact our team to learn more.

]]>
https://blogs.perficient.com/2021/11/05/10-microsoft-ignite-announcements-fall-2021/feed/ 0 299973