Microsoft

Blog Categories

Subscribe to RSS feed

Archives

Unable to Install Exchange 2010 SP1 Unified Messaging Role

I recently ran into the following issue while deploying Exchange 2010 for one of my customers:

Background:

Multi-server, multi-site Exchange environment consisting of the following:

  • 3 Mailbox Servers
    • Server 2008 R2
    • Exchange 2010 SP1
  • 3 HUB/CAS/UM Servers
    • Server 2008 R2
    • Exchange 2010 SP1

In order to install the UM Role for Exchange 2010 the following two prerequisites must first be downloaded and installed on your Exchange 2010 Server:

  • Unified Communications Managed API 2.0, Core Runtime
  • Microsoft Speech Platform – Server Runtime

Problem Description:

With both prerequisites listed above installed, the Readiness Check for installing the Exchange 2010 UM Role fails reporting that the Speech Platform Runtime is not installed. (Note that I’m performing the installation using the Exchange 2010 SP1 media.)

Resolution:

There are multiple versions of the Speech Platform Runtime. Since this was a new installation, I downloaded and installed version 10.2, which was released on 9/3/2010. With version 10.2 installed, the Exchange 2010 SP1 Readiness Check would not recognize that the Speech Platform Runtime was installed. I uninstalled version 10.2 of the Speech Platform Runtime and installed version 10.1 released on 6/12/2010 instead. After version 10.1 was installed, the Readiness Check completed successfully and I was able to install the UM Role. I’m guessing this must be a version mismatch bug in Exchange 2010 SP1.

Tags: , ,

Leave a Reply